How do I get the SprogII to work with Raspberry Pi?

The Linux version of JMRI supplied on the CD with the SprogII is for 386 systems. However, the latest JMRI release includes ARM support.  There is a script which will install this automatically. Before you execute this script, trash the the incorrect JMRI folder and trash the “JMRI Preferences” folder which is called the “.JMRI” folder, (the “dot JMRI folder”) which is hidden on your home directory.

https://github.com/proffalken/JMR-Pi

sudo apt-get install git
git clone https://github.com/proffalken/JMR-Pi
cd JMR-Pi
sudo ./setup.sh

Hot tip: If you get an error use Synaptic to check you have “librxtx-java”

 

Advertisements